Tag: Android studio

Studio Android 2.3 projet de gradle rafraîchissant prenant pour toujours

J'ai mis à jour mon studio Android jusqu'à la nouvelle version 2.3 et j'ai été invité à convertir mon projet pour faire correspondre les nouveaux formats que j'ai faits. On m'a demandé de mettre à jour la version de gradle et je l'ai fait. Maintenant une éternité plus tard, elle rafraîchit mon projet gradle. Je […]

La méthode DSL de Gradle n'a pas été trouvée: 'multiDexEnabled ()'

J'ai suivi le guide multidex à https://developer.android.com/tools/building/multidex.html Mais je reçois cette erreur. La méthode DSL Gradle n'a pas été trouvée: 'multiDexEnabled ()' . J'ai mis à jour les outils Android Built, le support de support Android et la bibliothèque. Voici mon fichier gradle.build. Est-ce que je fais quelque chose de mal ici? Could not find […]

Comment exporter la bibliothèque AAR avec sa documentation?

Je me demande pourquoi ma bibliothèque a toujours perdu sa documentation une fois qu'elle a été construite au format AAR. En outre, Android Studio rétrécie le code, c'est-à-dire que le code avant la construction est toujours différent avec le code après avoir été intégré au format AAR, aucun des originaux. Je veux que ma bibliothèque […]

Est-il possible d'intégrer Dagger et AspectJ dans un projet Android Studio?

Je travaille dans un projet Android où j'utilise Dagger pour l'injection de dépendance. Je ne sais pas grand-chose sur Gradle, mais dans la mesure où je comprends, les annotations de Dagger sont traitées par son compilateur une fois que le projet a été construit. Il n'y a aucun problème à configurer comme l'indique le guide […]

Les versions les plus récentes d'Android Studio et seulement deux annuaires drawable – drawable et drawable-v21

Avec les anciennes versions d'Android Studio, tous les dossiers débrochables du compartiment ont été créés par défaut (c'est-à-dire: mdpi drawable, drawable-hdpi, etc.). Dans les versions plus récentes d'Android Studio, il ne fournit que drawable et drawable-v21. Pourquoi donc? Y a-t-il une raison pour laquelle Android (dans sa sagesse infinie) ne vous donne plus les dossiers […]

Erreur de dépendance lors de l'utilisation de la bibliothèque aar

J'ai un module avec un fichier .aar dans un dossier libs. J'ai utilisé la solution posté ici [1]: http://kevinpelgrims.com/blog/2014/05/18/reference-a-local-aar-in-your-android-project/ pour ajouter le fichier .aar en tant que dépendance Et a pu compiler le module correctement. Maintenant, je souhaite utiliser ce module comme une dépendance du module principal dans mon projet et la compilation. Cependant, lorsque […]

Configuration pour une combinaison spécifique de saveur gradle

Je me demande s'il est possible de fournir des fichiers ou des paramètres de configuration pour une combinaison de groupes de saveurs spécifiques. Par exemple, j'ai 2 groupes de saveurs, avec 2 saveurs différentes chacune: Flavor Group: Version V2 V3 Groupe Saveur: Type gratuit plein Lorsque commandé "Type", "Version", je peux créer 4 saveurs différentes […]

Android Studio 2.0 build gradle error

Je viens de mettre à jour Android Studio vers la version 2.0 construit le 5 avril 2016 depuis un canal stable et j'ai maintenant une étrange erreur lorsque j'essaie de construire mon projet: Ignorer l'attribut InnerClasses pour une classe interne anonyme (org.apache.commons.collections.BeanMap $ 1) qui ne comporte pas d'attribut EnclosingMethod associé. Cette classe a probablement […]

Comment utiliser Gradle pour générer JavaDoc dans Android Studio?

Je ne trouve aucune documentation sur la façon de configurer mon fichier Gradle pour créer JavaDoc pour mon projet. J'ai déjà essayé quelques extraits de SO et des articles de blog, mais aucun d'entre eux semble fonctionner ou ils ne fournissent pas de contexte. C'est mon fichier Gradle. Que dois-je faire pour ajouter une tâche […]

Android Studio SDK n'est pas compatible avec Windows

J'ai installé Android Studio dans Windows 10. Lorsque j'ouvre Android SDK Manager et que j'essaie d'installer la plate-forme 2.2 SDK, j'ai le problème. Ce n'est pas compatible avec Windows et je ne peux pas l'installer. J'ai attaché une capture d'écran du problème. Je ne peux pas installer une version inférieure à 4.0 (API 14).

coAndroid est un fan Android de Google, tout sur les téléphones Android, Android Wear, Android Dev et Android Games Apps.